Envoyer un stream video vers le decodeur sagem problem

Pour discuter de tout ce qui concerne la TV d'Orange

Messagepar birdwing » 22 Mai 2009, 08:32

Bonjour,

donc voici les caractéristiques de mes connections car cela ne fonctionne toujours pas :-(

eth0 :
Image

eth1 :
Image

J'ouvre VLC et utilise la liste de diffusion 'BouquetTV_Orange_v2.2.m3u' mais rien ne s'affiche dans VLC :-/
LiveBox SAGEM ITAD83 SD FT - VLC media player 0.9.9a Grishenko
Ubuntu 9.04 - AMD Sempron(tm) 2800+ 2Ghz - 2Go RAM
birdwing
 
Messages: 13
Inscription: 15 Mai 2009, 11:55

Messagepar JJR44 » 22 Mai 2009, 09:34

Bonjour birdwing,

As-tu lu cette discussion : http://forum.porciello.com/phpBB3/viewtopic.php?p=1755#top, et en particulier le dernier post de hugo91 ?

JJR
JJR44
 
Messages: 267
Inscription: 10 Aoû 2008, 23:15

Messagepar birdwing » 22 Mai 2009, 12:14

@JJR44, j'ai regardé et écrit le script qu'il propose en début de topic, puisque le lien proposé ensuite n'aboutit pas.
J'en ai donné les résultats dedans (pour éviter de polluer celui-là), mais môrche toujours pô arf.

Y-aurait-il des choses à vérifier encore ?!
par exemple je crois avoir constaté que je n'ai pas de disque avec une partition swap. Cela aurait-il une incidence, ou autre chose je ne sais pas.
Y-aurait-il une sorte de checklist pour Ubuntu ?!
LiveBox SAGEM ITAD83 SD FT - VLC media player 0.9.9a Grishenko
Ubuntu 9.04 - AMD Sempron(tm) 2800+ 2Ghz - 2Go RAM
birdwing
 
Messages: 13
Inscription: 15 Mai 2009, 11:55

Messagepar JJR44 » 22 Mai 2009, 21:11

@ birdwing,

Désolé mais je n'utilise que Windows ...

JJR
JJR44
 
Messages: 267
Inscription: 10 Aoû 2008, 23:15

Messagepar senufo » 04 Juin 2009, 11:40

Bonjour,

J'utilise le même type de config que toi avec une carte réseau (eh0) pour internet et une carte réseau (eth1) pour le TV Livebox. Les 2 cartes étant sur des réseaux différents (192.168.0.2 et 192.168.1.2)

Il faut bien faire attention aux options du routage.
Vérifier que :

Code: Tout sélectionner
sysctl net.ipv4.conf.default.rp_filter
net.ipv4.conf.all.rp_filter = 0

sysctl  net.ipv4.conf.all.rp_filter
net.ipv4.conf.all.rp_filter = 0


Si c'est égal à 1 le routage multicast ne fonctionne pas

après il faut ajouter le routage multicast

Code: Tout sélectionner
route add -net 224.0.0.0 netmask 240.0.0.0 dev eth1


et maintenant cela devrait fonctionner
senufo
 
Messages: 6
Inscription: 23 Oct 2008, 18:45

Messagepar birdwing » 14 Juin 2009, 16:18

je commence à y perdre mon latin dans tout ça.

apparemment pour moi j'ai :
*eth0 : Internet
*eth1 : TV


Code: Tout sélectionner
~$ ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:13:8f:08:12:1b 
          inet adr:192.168.1.7  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::213:8fff:fe08:121b/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:61351 erreurs:0 :0 overruns:0 frame:0
          TX packets:56444 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:87780052 (87.7 MB) Octets transmis:11342417 (11.3 MB)
          Interruption:23 Adresse de base:0xd00


Code: Tout sélectionner
~$ ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:60:97:0c:d6:ed 
          inet adr:192.168.0.20  Bcast:192.168.0.255  Masque:255.255.255.0
          adr inet6: fe80::260:97ff:fe0c:d6ed/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Packets reçus:70 erreurs:0 :0 overruns:0 frame:0
          TX packets:333 errors:0 dropped:0 overruns:0 carrier:2
          collisions:0 lg file transmission:1000
          Octets reçus:4200 (4.2 KB) Octets transmis:102121 (102.1 KB)
          Interruption:18 Adresse de base:0xd400


Mais avec ce genre de config plus accès au net :x
Je me suis donc remis en DHCP :?

Code: Tout sélectionner
~$ sysctl net.ipv4.conf.default.rp_filter
net.ipv4.conf.default.rp_filter = 1
~$ sysctl  net.ipv4.conf.all.rp_filter
net.ipv4.conf.all.rp_filter = 1

~$ sudo sysctl -w net.ipv4.conf.eth0.rp_filter=0
net.ipv4.conf.eth0.rp_filter = 0
~$ sudo sysctl -w net.ipv4.conf.all.rp_filter=0
net.ipv4.conf.all.rp_filter = 0
~$ sudo sysctl -w net.ipv4.conf.eth0.mc_forwarding=0
error: permission denied on key 'net.ipv4.conf.eth0.mc_forwarding'
~$ sudo sysctl -w net.ipv4.conf.all.mc_forwarding=0
error: permission denied on key 'net.ipv4.conf.all.mc_forwarding'

~$ sysctl net.ipv4.conf.default.rp_filter
net.ipv4.conf.default.rp_filter = 1
~$ sysctl  net.ipv4.conf.all.rp_filter
net.ipv4.conf.all.rp_filter = 0


Code: Tout sélectionner
~$ sudo sysctl net.ipv4.conf.eth0
error: "Invalid argument" reading key "n~$ route add -net 224.0.0.0 netmask 240.0.0.0 dev eth1
SIOCADDRT: Opération non permise
~$ sudo route add -net 224.0.0.0 netmask 240.0.0.0 dev eth1et.ipv4.conf.eth0"
LiveBox SAGEM ITAD83 SD FT - VLC media player 0.9.9a Grishenko
Ubuntu 9.04 - AMD Sempron(tm) 2800+ 2Ghz - 2Go RAM
birdwing
 
Messages: 13
Inscription: 15 Mai 2009, 11:55

Messagepar Tof » 15 Aoû 2009, 20:02

Tutorial mis à jour pour VLC 1.0.x :
http://www.porciello.com/inventel/tv_diffuser.htm
Les questions se posent sur le forum et non par MP. Une réponse faite à une personne peut servir à d'autres.
Tof
Administrateur
 
Messages: 995
Inscription: 08 Jan 2005, 06:56

Précédente

Retourner vers La TV Orange

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron